IPv4 CIDR- & Subnetz-Referenztabelle (/0 bis /32)

Umfassende Referenz für Netzwerkmasken, Wildcards, Gesamtanzahl und nutzbare Hosts.

CIDR Subnetzmaske Wildcard-Maske Gesamt-IPs Nutzbare Hosts Klasse & Typischer Einsatzbereich
/32 255.255.255.255 0.0.0.0 1 1 Host-Route / Loopback (Einzelne IP-Adresse, kein Subnetz)
/31 255.255.255.254 0.0.0.1 2 2 Point-to-Point Link (RFC 3021, Router-Verbindung ohne Netz-/Broadcast-Verlust)
/30 255.255.255.252 0.0.0.3 4 2 Traditioneller Point-to-Point Link (1 Netz-ID, 2 Hosts, 1 Broadcast)
/29 255.255.255.248 0.0.0.7 8 6 Kleines Subnetz (z. B. öffentlicher ISP-IP-Block mit Router & Servern)
/28 255.255.255.240 0.0.0.15 16 14 Kleine DMZ, Server-Cluster oder isoliertes Management-VLAN
/27 255.255.255.224 0.0.0.31 32 30 Kleine Abteilung oder abgetrenntes Gast-WLAN
/26 255.255.255.192 0.0.0.63 64 62 Mittelgroßes Abteilungs-Subnetz
/25 255.255.255.128 0.0.0.127 128 126 Halbes Class C Netz (z. B. Aufteilung eines /24 in zwei Netze)
/24 255.255.255.0 0.0.0.255 256 254 Class C Äquivalent · Weltweiter Standard für Heim- & Büro-LANs
/23 255.255.254.0 0.0.1.255 512 510 Erweitertes Firmennetzwerk (2 zusammenhängende /24 Blöcke)
/22 255.255.252.0 0.0.3.255 1.024 1.022 Größere Unternehmensstandorte, Hotels oder Konferenz-WLANs
/21 255.255.248.0 0.0.7.255 2.048 2.046 Unternehmensnetzwerk (8 zusammenhängende /24 Blöcke)
/20 255.255.240.0 0.0.15.255 4.096 4.094 Großes Firmennetzwerk oder Campus-VLAN
/19 255.255.224.0 0.0.31.255 8.192 8.190 Große Organisationen und Universitätsnetze
/18 255.255.192.0 0.0.63.255 16.384 16.382 Regionale Provider-Netze & Großunternehmen
/17 255.255.128.0 0.0.127.255 32.768 32.766 Halbes Class B Netz
/16 255.255.0.0 0.0.255.255 65.536 65.534 Class B Äquivalent · z. B. privates Netz 172.16.0.0/16
/15 255.254.0.0 0.1.255.255 131.072 131.070 Großes Rechenzentrum / ISP-Backbone
/14 255.252.0.0 0.3.255.255 262.144 262.142 Großes Rechenzentrum / ISP-Backbone
/13 255.248.0.0 0.7.255.255 524.288 524.286 Telekommunikationsanbieter & Cloud-Infrastruktur
/12 255.240.0.0 0.15.255.255 1.048.576 1.048.574 Gesamter RFC 1918 Block 172.16.0.0/12 (16 Class B Netze)
/11 255.224.0.0 0.31.255.255 2.097.152 2.097.150 Carrier-Netze & globale Cloud-Provider
/10 255.192.0.0 0.63.255.255 4.194.304 4.194.302 RFC 6598 Carrier-Grade NAT (CGNAT) 100.64.0.0/10
/9 255.128.0.0 0.127.255.255 8.388.608 8.388.606 Halbes Class A Netz
/8 255.0.0.0 0.255.255.255 16.777.216 16.777.214 Class A Äquivalent · z. B. privates Netz 10.0.0.0/8 oder 127.0.0.0/8
/7 254.0.0.0 1.255.255.255 33.554.432 33.554.430 Große RIR-Allokation (RIPE, ARIN, APNIC)
/6 252.0.0.0 3.255.255.255 67.108.864 67.108.862 Große RIR-Allokation
/5 248.0.0.0 7.255.255.255 134.217.728 134.217.726 Große RIR-Allokation
/4 240.0.0.0 15.255.255.255 268.435.456 268.435.454 Class E (Experimentell / Reserviert 240.0.0.0/4) & Class D (Multicast 224.0.0.0/4)
/3 224.0.0.0 31.255.255.255 536.870.912 536.870.910 Großes BGP-Supernetz
/2 192.0.0.0 63.255.255.255 1.073.741.824 1.073.741.822 Ein Viertel des gesamten IPv4-Adressraums
/1 128.0.0.0 127.255.255.255 2.147.483.648 2.147.483.646 Die Hälfte des gesamten IPv4-Adressraums
/0 0.0.0.0 255.255.255.255 4.294.967.296 4.294.967.296 Default Route (Alle IPv4-Adressen weltweit · 0.0.0.0/0)

Mathematische Berechnung nutzbarer Hosts

Die Anzahl aller Adressen in einem Subnetz ergibt sich aus $2^{(32 - \text{CIDR})}$. Bei klassischen Netzen (/1 bis /30) werden 2 Adressen abgezogen:

  • Netzwerk-ID: Die erste IP des Blocks (z. B. 192.168.1.0).
  • Broadcast-Adresse: Die letzte IP des Blocks (z. B. 192.168.1.255).
  • Formel: $\text{Nutzbare Hosts} = 2^{(32 - \text{CIDR})} - 2$

Die Ausnahmen: /31 und /32

/31 (RFC 3021): Auf direkten Point-to-Point Verbindungen zwischen zwei Routern wird weder eine Netzwerk-ID noch eine Broadcast-Adresse benötigt. Beide Adressen sind nutzbar. Dies spart weltweit wertvollen IPv4-Adressraum.

/32 (Host-Route): Bezeichnet exakt ein einzelnes Gerät (z. B. eine Firewall-Regel, Loopback-Interface oder VPN-Client-Zuweisung).

Was ist eine Wildcard-Maske?

Die Wildcard-Maske (inverse Subnetzmaske) wird vor allem bei Cisco-Routern (OSPF, EIGRP, ACLs) verwendet. Sie entsteht durch Subtraktion der Subnetzmaske von 255.255.255.255. Eine 0 im Bitmuster bedeutet „muss exakt übereinstimmen“, eine 1 bedeutet „egal (Wildcard)“.

Private IPv4-Bereiche (RFC 1918)

  • 10.0.0.0/8: 1 großes Class A Netz (16.777.214 Hosts)
  • 172.16.0.0/12: 16 Class B Netze (172.16.0.0 bis 172.31.255.255)
  • 192.168.0.0/16: 256 Class C Netze (192.168.0.0 bis 192.168.255.255)

Made with ♥️ by Mailuft Digital GmbH.

Datenschutz · Impressum